Home Forums LoveStory Redirect to users page after login

Redirect to users page after login

  • PedroManuel1

    Hello Ihor, I would like you to redirect me to the “Users” page instead of “My profile” after login.

    PedroManuel1

    Sorry, I wanted to refer to the page “Profiles” instead of “Users”.

    ihor Staff

    Please sign in or register to view replies from the support staff.

    PedroManuel1

    Thank you very much, now the problem is that when a user logins the page in another language the page is not translated in that language, I have to translate wpml.

    ihor Staff

    Please sign in or register to view replies from the support staff.

    PedroManuel1

    Okay, so the following code:
    $ajax_url = ‘http://my-site.com/wp-content/plugins/my-plugin/handle-ajax.php’;
    $my_current_lang = apply_filters( ‘wpml_current_language’, NULL );
    if ( $my_current_lang ) {
    $ajax_url = add_query_arg( ‘wpml_lang’, $my_current_lang, $ajax_url );
    // $ajax_url will be something like ‘http://my-site.com/wp-content/plugins/my-plugin/handle-ajax.php?wpml_lang=es’
    },

    and the following code:

    if ( isset( $_GET[ ‘wpml_lang’ ] ) ) {
    do_action( ‘wpml_switch_language’, $_GET[ ‘wpml_lang’ ] ); // switch the content language
    }

    // Run other content queries.

    where do I attach it?

    ihor Staff

    Please sign in or register to view replies from the support staff.

    PedroManuel1

    Okay, Anyway thank you very much.

    PedroManuel1

    Hi Ihor, I have commented this problem to WPML technical support and they have told me the following: “Your LoveStory theme is not on our compatibility list. However, this does not necessarily mean that it is not, our team simply has not tried so far.https: //wpml.org/documentation/theme-compatibility/ Now, according to the author’s description, it is a custom code that is beyond the reach of the support or maybe we could start an integration work with the author if you are interested in working with us”.

    PedroManuel1

    I have also been told by WPML support: “I have created a test site for you. You can access it simply by clicking on the following link: http://lucky-willet.w5.wpsandbox.pro?upass= t25X0z3tUCuJ The idea is to upload the latest version of your LoveStory theme and help us reproduce the problem, so if it is a compatibility issue, we can speed up the process and contact our Compatibility Team and work with the author in solving your problem. You don’t have to recreate your site, just install the minimum necessary to reproduce the problem. Moreover, you can also share this link with the subject’s author: https://wpml.org/documentation/ theme-compatibility / go-global-program / “

    PedroManuel1

    They also tell me the following: “I am seeing erratic behavior even when WPML is not activated. – You go to the home page. – You open a session from the front end. – In the URL you are redirected to / wp-admin / and a Desktop bar is displayed in the middle of the front-end. If the subject redirects to / wp-admin / there is no way that WPML can retain the language parameter. Could you correct this first with the author? “

    ihor Staff

    Please sign in or register to view replies from the support staff.

    PedroManuel1

    Okay, could you write me the custom code for this theme in the login function and to add the language parameters to the login form?

    ihor Staff

    Please sign in or register to view replies from the support staff.

    PedroManuel1

    Okay, thank you very much for your atention.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.