Home Forums Midway How to stop site wide title being added to custom title

How to stop site wide title being added to custom title

  • polandexplorer

    Hi

    I am using the plugin “add meta tags”, and have posted a question concerning the above on the plugin support.

    I wish to use a custom title on the front page such as

    “Poland Travel Guide – all about the country of Poland”

    When I add this on the page under custom title I get

    Poland Travel Guide – all about the country of PolandPoland Travel Guide

    The site wide title is still added (and without spacing)

    How can I resolve this as I expected the custom title to cancel the site wide one, or at least create correct spacing.

    I do not want to cancel the site wide title on other pages just on custom titles.

    The author has replied

    This issue is most probably related to the theme…. I tested the plugin with the twentyfifteen theme and a static page as the front page. I could not reproduce the issue. So, I’m going to mark this topic as resolved. Please feel free to reopen if you are able to reproduce the problem with the default themes.

    Any ideas what code i need to adjust to correct this.

    thanks

    polandexplorer

    Ok fixed this by changing header code to

    <title><?php wp_title( '- Poland Travel Guide', true, 'right' ); ?></title>

    ihor Staff

    Please sign in or register to view replies from the support staff.

    Diane

    Thank you so much for posting this! I had the exact same problem in the Replay theme.
    At first I thought I had to adjust the Title & Metas settings in the Yoast SEO plugin, but that did not have the result I wanted.
    I changed the php code in header.php to <title><?php wp_title('|', true, 'right'); ?></title>
    The home page tab is now showing what I wanted to see there. No adding of the site name again at the end. Thanks again!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.