Home Forums LoveStory Checkbox at registration and activation link

Checkbox at registration and activation link

  • Adam985

    Welcome back,

    I need information on how to effectively implement checboxes on the registration page. From what I was able to find on this forum according to your recommendations, I added a modified line for your needs:

    <P>
    <label for = “terms”> <input type = “checkbox” id = “terms” name = “terms” required> I agree to Terms of Use </ label>
    </ P>

    and it actually appears. This is already half the battle. However, you can still sign up without wantingbox. I care about the user having to approve, for example, the regulations before registering on the site with a click, is it possible? Of course, I want the registration to continue smoothly and without reservations.

    PS. Is it possible to make the activation link (%link%) in the mail after registration displayed in the form of a link rather than text? From my observations, it appears that it comes in the form of text to copy and paste in the transceiver window. Of course not on every mailbox, but in most of my case studies.

    ihor Staff

    Please sign in or register to view replies from the support staff.

    Adam985

    hi,

    1. It looks like it works and the account can be set up only after approval (after completing the content, there is information that not all fields are marked) – that’s what I meant, thanks a lot. I could not change it myself.

    2. Link text here is also ok. Only I understand that the form of natural HTML can not be set here for the user, because we do not know the entire address for the given type: https: //domena.com/register?activate=fc04a068425335dcb7b32acb7b4dd132&user=353.

    In% link% that’s how it was shown, but not always email accounts pointed to the address as a link.

    ihor Staff

    Please sign in or register to view replies from the support staff.

    prometeosp

    Dear ihor,

    Please could you send me the code to add a checkbox in the registration form?

    I added the following code, but is not working:

    “<div class=”contenedor-terminos”>
    <input type=”checkbox” data-required=”1″ name=”terminos” id=”terminos” value=”0″><label for=”terminos”><span class=”span-terminos”> Acepto el /aviso-legal/” class=”enlace-terminos”>aviso legal, la /politica-de-privacidad/” class=”enlace-terminos”>política de privacidad y las /condiciones-generales/” class=”enlace-terminos”>condiciones generales.</span>
    </div>”

    ihor Staff

    Please sign in or register to view replies from the support staff.

    prometeosp

    Hello ihor,

    I did it indeed but is not working.

    Maybe I should change registerUser function?

    I don’t know why but, the new element “terminos” is not in the array when I debug the RegisterUser function.

    Some ideas?

    Frank

    prometeosp

    This is an extract of the code:

    “<div class=”column sixcol last”>
    <div class=”field-wrap”>
    <input type=”password” name=”user_password_repeat” placeholder=”<?php _e(‘Repite la clave’,’lovestory’); ?>” />
    </div>
    </div>
    <?php if(ThemexCore::checkOption(‘user_captcha’)) { ?>
    <div class=”form-captcha”>
    assets/images/captcha/captcha.php” alt=”” />
    <input type=”text” name=”captcha” id=”captcha” size=”6″ value=”” />
    </div>
    <div class=”clear”></div>
    <?php } ?>
    <div class=”field-wrap”>
    <label><input type=”checkbox” name=”terminos” id=”terminos” value=”0″ >
    Acepto el /aviso-legal/” class=”enlace-terminos”>aviso legal, la /politica-de-privacidad/” class=”enlace-terminos”>política de privacidad y las /condiciones-generales/” class=”enlace-terminos”>condiciones generales.</label>
    </div>
    <div class=”clear”></div>
    <?php _e(‘Registrarme’, ‘lovestory’); ?>

    prometeosp

    These are the elements of $data array:

    array(7)
    user_login: “”
    user_email: “”
    user_password: “”
    user_password_repeat: “”
    captcha: “”
    user_action: “”
    nonce: “”

    As you can see the “terminos” element is not part of the array

    Thanks

    ihor Staff

    Please sign in or register to view replies from the support staff.

    prometeosp

    Dear ihor,

    I sent you the access yesterday. Did you access the site?

    Kind regards,

    Juan

    prometeosp

    Hello ihor,

    Any updates with this problem?

    Thanks!

    ihor Staff

    Please sign in or register to view replies from the support staff.

    prometeosp

    Hi ihor,

    I changed the code as you requested and the element “terminos” is still not in the array.

    What permissions do you need to access to the code?

    Kind regards,

    Frank

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.